Resumindo

O SCIM (System for Cross-domain Identity Management) é um protocolo aberto, baseado em REST/JSON, que automatiza a criação, atualização e remoção de contas de identidade de usuários em aplicativos na nuvem. Ao conectar provedores de identidade diretamente a provedores de serviços (aplicativos SaaS), o SCIM simplifica o User Lifecycle Management, reduz a zero os períodos de exposição da TI ao desligamento de funcionários e diminui em até 50% os tíquetes de redefinição de senha.

SCIM, ou Sistema para Gerenciamento de Identidade entre Domínios, é um padrão aberto que automatiza o provisionamento de usuários. Foi criado em 2011, quando a arquitetura baseada em nuvem se tornou o padrão da indústria. O SCIM comunica dados de identidade do usuário entre provedores de identidade (IdPs) — sistemas que gerenciam identidades de usuários — e provedores de serviços (SPs) — aplicativos que consomem dados de identidade (como aplicativos SaaS corporativos).

SCIM: especificações principais e panorama técnico

AtributoDetalhes
Nome completoSistema para gerenciamento de identidade entre domínios
Padrão atualSCIM 2.0 (Especificações IETF: RFC 7642, RFC 7643, RFC 7644)
ArquiteturaAPIs RESTful usando formatos de payload JSON
Função principalOperações CRUD (criar, ler, atualizar, excluir) automatizadas para perfis do usuário e grupos
Agentes principaisIdP (cliente SCIM), SP (servidor SCIM)

Assista: o que é SCIM?

Vidyard video

Por que as empresas devem usar o SCIM para o gerenciamento de identidades?

O SCIM torna os dados do usuário mais seguros e simplifica a experiência do usuário, automatizando o gerenciamento do ciclo de vida da identidade do usuário. 

Principais benefícios do SCIM

  • Automatiza o provisionamento e o desprovisionamento de usuários: elimina a criação e remoção manual de contas
  • Reduz a carga de trabalho da TI: Libera os departamentos de TI do desenvolvimento e da manutenção de integrações personalizadas
  • Melhora a conformidade com a segurança: Garante a aplicação consistente das políticas de segurança em todos os aplicativos.
  • Reduz o risco de erros: a transferência automática de dados minimiza erros humanos.
  • Permite o Single Sign-On (SSO): Simplifica os fluxos de trabalho dos funcionários e reduz as solicitações de redefinição de senha em até 50%
  • Escalabilidade conforme o crescimento da empresa: lida com o aumento de contas de usuários à medida que as organizações se expandem

À medida que as empresas crescem, inovam e vivenciam a rotatividade de funcionários, o número de contas do usuário aumenta exponencialmente. Os funcionários as utilizam para tudo, desde a gestão de relacionamento com o cliente até a colaboração em equipe. Solicitações para adicionar ou excluir usuários, alterar permissões e adicionar novos tipos de conta consomem um tempo valioso do departamento de TI.

Com o SCIM, as equipes de TI podem criar identidades de usuário diretamente em uma ferramenta como o Okta ou importá-las de sistemas externos, como softwares de RH ou Active Directory. Como o SCIM é um padrão aberto, os aplicativos armazenam e comunicam dados do usuário de forma consistente em diferentes ferramentas. Isso permite que os departamentos de TI automatizem o provisionamento e o desprovisionamento ao mesmo tempo que centralizam as permissões e o gerenciamento de grupos. Além disso, como a transferência de dados é automática, o risco de erros é reduzido.

Os departamentos de TI não precisam mais desenvolver e atualizar constantemente integrações personalizadas que conectam diretórios da empresa a aplicativos externos. Funcionários que não fazem parte da área de TI podem usar o SSO para otimizar seus Workflows e reduzir as solicitações de redefinição de senha em até 50%.

Ao mesmo tempo, a adoção do SCIM reduz muitos dos riscos de segurança que as empresas enfrentam. Quando os funcionários não precisam mais fazer login individualmente em cada uma de suas contas, as empresas podem garantir a conformidade com as políticas de segurança. Isso também atenua os riscos associados à reutilização de senhas por funcionários em diferentes ferramentas. À medida que as equipes desenvolvem novos fluxos de trabalho e adotam novos apps, as empresas podem acompanhar essas mudanças sem medo de perder o controle das contas.

SCIM versus provisionamento manual: comparação operacional

DestaqueProvisionamento automatizado de SCIMProvisionamento manual de TI
VelocidadeSincronização instantânea e automáticaEntrada manual e demorada
Taxa de errosBaixa (transferência automatizada de dados)Alto (suscetível a erros humanos)
EscalabilidadeSuporta milhares de usuários com facilidadeTorna-se incontrolável em grande escala.
Exposição no desligamentoDesprovisionamento imediato quando os funcionários saemA remoção tardia do acesso cria vulnerabilidades
carga de trabalho de TIManutenção contínua mínimaRequer atenção constante

Como funciona o SCIM entre provedores de identidade e aplicativos SaaS?

SCIM é um protocolo baseado em REST e JSON que define funções de cliente e servidor. Um cliente geralmente é um IdP, como a Okta, que mantém um diretório robusto de identidades de usuários. Um provedor de serviços (SP, na sigla em inglês) geralmente é um app SaaS, como o Box ou o Slack, que precisa de um subconjunto de informações dessas identidades.

Processo passo a passo

  1. O provedor de identidade cria ou atualiza um usuário: um administrador adiciona um novo funcionário ou modifica os dados de um usuário existente no IdP
  2. As alterações são sincronizadas automaticamente por meio do protocolo SCIM: o IdP envia a atualização para os SPs conectados usando chamadas de API SCIM padronizadas.
  3. O provedor de serviços recebe e aplica as alterações: O SP cria, atualiza ou remove a conta do usuário conforme necessário
  4. O usuário obtém acesso simplificado: o usuário final pode acessar imediatamente os aplicativos com perfis e permissões atualizados.

O IdP também pode ler identidades do SP para adicioná-las ao seu diretório e detectar valores incorretos no SP que poderiam criar vulnerabilidades de segurança.

Como implementar o SCIM em seu ambiente de TI

A Okta oferece suporte a integrações de provisionamento— incluindo conectores baseados em SCIM 2.0 — com centenas de aplicativos líderes de mercado. Também oferecemos suporte a SSO em milhares de apps e fornecemos integrações de API pré-construídas para aplicativos líderes do setor, para que você possa comunicar seus dados de usuário de forma rápida e segura. 

Veja como o Okta Lifecycle Management pode ajudar você a simplificar o gerenciamento de identidades de usuários.

Você é um desenvolvedor que deseja integrar seu app ao Okta?

Acelere sua integração com o Okta usando nosso guia de integração de provisionamento SCIM. Para começar passo a passo, explore nosso Caminho de aprendizagem para automatizar o provisionamento de usuários e configure o provisionamento SCIM em seus aplicativos de forma integrada.

Perguntas frequentes

SCIM significa Sistema para Gerenciamento de Identidade entre Domínios.

Sim. O SCIM utiliza chamadas de API REST seguras via HTTPS e reduz os riscos de segurança ao automatizar o desprovisionamento imediato dos usuários quando eles saem da empresa.

Milhares de aplicativos Enterprise suporte a SCIM, incluindo populares apps SaaS como Box, Slack, Salesforce e Microsoft 365.

O SCIM 2.0 é a versão atual, definida pelos padrões IETF RFC 7642, RFC 7643 e RFC 7644.

O SSO lida com a autenticação (verificando a identidade do usuário ao fazer login), enquanto o SCIM lida com o provisionamento (criando, atualizando e excluindo contas de usuário e permissões). Eles trabalham juntos para um gerenciamento de identidades completo.

Continue sua jornada de identidade